Slow cube loading?

#1

Hi all,

Was wondering if y’all had any idea why it is taking cubes so long to load. I am used to a certain amount of slowness but think that a minute per cube is approaching the ridiculous side. I’m not talking large cubes either, even little picky corner bits are taking that long. When I open the console there is a lot of “Failed to load resource: the server responded with a status of 403 ()” errors, as well as “omni.js:3 watch select for wrong task id 2188415 2194563” (although the numbers on that last one keep changing.)

The game had already slowed down after the introduction of mystic, but since the crash last week it is at risk of becoming unplayable.

Let me know if there’s anything I can do to help y’all figure it out :slight_smile:

Atani

3 Likes
#2

Yeah, I agree there were probs since end feb - start march, which got progressively worse and then after crash last week game’s downright almost unplayable. Very slow loading in both inspect and normal play, lots and i mean loooots of 404/403 (forbidden)'s whenever I click the reap/submit button.

Same 404s whenever I inspect any cube which means most times 3D doesn’t load and I have to retrace everything. Then on refresh sometimes all ok, most times overview won’t load, some buttons like start playing “no avail cubes” or SL won’t load, so refresh again, so in every refresh I may have to do 10 more refreshes for me to be able to play/scout again and that’s not like once per day, that’s every 2-3 cubes… Then also click new entry and it doesn’t do nada b/c 403’ forbidden and click unclick 40 times and still nothing so either have to open a new ew tab and hope it works or another 10 refreshes.

New features are nice and all but with bugs and frustration like this…if the game’s almost unplayable does anyone care for shiny new things that may or may not work ok?

It’s just frustrating and if ppl with 3-4 years of play time (loyal and caring) are leaving or thinking of leaving b/c of it I imagine a new player with 0 time played won’t even bother emailing, he/she has just left.

2 Likes
#3

in case it helps pin down the overall issue, I’m accessing from Baltimore via Comcast (so, likely closer wrt to network) and have been having only very sporadic load-time issues over the same period, with no 403 or 404 seen.

3 Likes
#4

Bulgaria, Europe here. Have some more technical info to provide.

During mornings (HQ nights) API timings vary between 200-400ms. But later in the day as America starts to wake up latency starts spiking with increasing frequency and google cloud (the dataset, cube segmentation and OV mesh host) starts slowing down. I have seen calls like /1.0/task/123456/aggregate and /1.0/task/123456/neighbours take upwards of 4-5 seconds to complete (they’re called when you click a cube in the OV).

During the marathon today I even saw the scythe heatmap taking 15 seconds (!) to load. I think such API timings are unacceptable and should be resolved to ensure a smooth experience.

Example:


3 Likes
#5

i also get 403-errors. Playing normally ok, guess thanks to preloading, but scything very bad. Takes seconds to see when i press scythe-button that i have scythed, then entering cube: takes long time for 2d-loading. It’s not only while USA still “sleeping”, had problem today while scything the marathon (till 8 am)

2 Likes
#6

Also: History loading is very very slow. When i play a cube, and see for example AI-merger i want to reap, i’m much faster to type cube-id into box, than opening History, and get id from there. (one opened, it’s ok)

2 Likes
#7

From France i got thoses super slow loading times too. And by loading times i mean slow OV refreshing, super slow 2d pictures loading, very extra slow toolbox refreshing. I got those 403/404 errors since february, as i already expleined it in my mail to Celia/Chris.
Like @susi, my history is really slow too, i sometimes need to close it and repoen hoping it work.

As @Nseraf said, i do not play that much now since few month because of this. I really like this science researching platform, and it’s only because it’s about science i still reap/complete, but i stoped playing since a while.

Like this picture, it’s all the time like this, with more red error than good loadings :

I tried all possibilities, from extensions removing, USA VPN, different browsers, another computer with default network settings…

And as @Nseraf said, i really would prefer the old good fast loading EW without any super new tools. Like Magic hand that i think noone use, or Z plane that could be load option.

2 Likes
#8

lol i use magic mode and the z plane!

1 Like
#9

yup, history loading has been the most noticeable thing for me

1 Like
#10

History loading has been awful for quite a while for me. But we are now clocking in at 4-5 mins before it loads. I ask it to load, and then go do something else for a while. :confused:

#11

history is almost useless as it is now, i do not have the patience to wait for it, and almost every time i open the history tab something else open instead. general slowness with the reap beiing registered and loading of cubes for reaping, for play the preloading is usually taking care of it but i have several times had to start tracing blind and hope i find the right path.
i have also had considerable difficulties the last couple of days with the site freezing and when reloading nothing work the first few tries

1 Like
#12

One of my favorite moment. After more or less 13 seconds waiting for toolbox infos :

So i finally change my mind and i go lost myself on youtube :confounded:

1 Like
#13

Perhaps this helps to find problem. Saw this error first time, no idea what it means :slight_smile:Was reapgrowing, 3d showed ov, 2d was not loading, after if left cube, scouts log was away.

1 Like
#14

From the Philippines, I get used to it since I always have slow internet lol, but still, it’s very annoying. Maybe this issue is linked to my issue of keyboard shortcuts not working, as shown in https://youtu.be/X_17ippN2e0 . Also, for some reason, even going back to overview is slow and even the cursor icons in 2d takes a long time to load.

1 Like
#15

I know this isn’t helpful info, but regular play cube loading was worse last night. I was able to load two zfish cubes in the amount of time it took for a regular cube to load so i could normal trace it (not inspect). It seemed to keep getting “hung up” at various times while loading in. For example, it got stuck at 63% and stayed there for a min of 30 seconds, then again at 95%.

1 Like
#16

yeah that happens to me a lot if I change cells often. (refresh only fixes it.)

#17

this wasn’t after changing cells though. this was straight up play as soon as the game loaded in. (and tbh, it is still unacceptable even if it were to be triggered by changing cells, imo)

1 Like
#18

ah and yeah.

#19

Ok guys… i totally don’t know why, but i tried to instal an older version of chrome (Version 48.0.2564.109 (64-bit)) and now 2d loading is very faster ! After a few hours, it still load 2d in 1 sec max.

I have no more 2d loading 403 errors, but still meshes 403 errors.

I now reinstalled the last 60 version and 2d loading is as slow at it was. So i don’t know what kind of changes google added since 48, but it affect connections.

1 Like
#20

Thanks for all of this input, folks! We are experiencing similar slowness at HQ itself. To take a stab at fixing it, there will be about 20 minutes of downtime at 6 PM EDT today (7/31), but if you continue to experience these issues afterward, please e-mail the type of info you’ve provided above to support@eyewire.org. If you have the ability to screen-record, feel free to do a timelapse to demonstrate how long a delay there is.

1 Like