Problems with Firefox and Safari (OSX Mavericks)

#1

I started playing about four days ago on Firefox, and everything worked perfectly. But a couple days ago, the site gave me the “WebGL Required” error, with a broken link to the wiki. I decided to wait a day to see if it was just a site-wide problem, but apparently it’s just me. I tried Safari, but after logging into Eyewire, the only thing on the screen is the top menu (minus the profile and log out buttons) and the word ‘overview’.

1 Like
#2

Hi TopQuark_

I’m sorry to hear you’re having trouble with WebGL. Firefox should have consistent support for WebGL, but sometimes Safari can still have issues (we recommend Chrome or Firefox first). Can you send us what version of Firefox/Safari you are using along with perhaps a screenshot of your web console (control+shift+k) in Firefox? That screenshot will allow us to see what, if any, errors are occurring under the hood.

Feel free to email us this info at support@eyewire.org

Best,
M.

1 Like
#3

Safari version 9.0.3 (9537.86.4.4)
Firefox version 43.0.4.

Console report -

EyeWire in Firefox -

“Find out how to enable it!” -

Eye Wire in Safari -

Sorry, not sure how to use spoilers here.

I could care less about Safari, I would just like it working on Firefox, my main browser.

EDIT: Oh, and it’s [cmd]+[opt]+k to open the console on OSX

1 Like
#4

Hey TopQuark,

Does this page load correctly for you? https://get.webgl.org/

1 Like
#5

It says, “Hmm. While your browser seems to support WebGL, it is disabled or
unavailable. If possible, please ensure that you are running the latest
drivers for your video card.” The help link just tells me to update my graphics drivers, but no patch haas been released for Mavericks.

1 Like
#6

I recommend trying the steps suggested in the answer here. It will reset some of your Firefox settings. After doing that, try the same url I linked before, and Eyewire.

1 Like
#7

Thanks, that fixed the EyeWire problem, but now I have a problem with web security certificates and my anti-virus, causing Firefox to not load any web pages. I worked around the problem by disabling the antivirus’ HTTPS scanning. I should be able to figure this one on my own. Still, it’s odd that WebGL would just stop working like that, just out of the blue. Thanks again.

1 Like