New -scythe vision and inspect- bug(s)


#1

Okay, so I've added these to the sheet as well, but I'm starting a forum thread, so that people who are inflicted by these 2 bugs can write up about it and maybe provide steps/info that may help devs (@Kelv) find the source of it and fix it (it's really I believe 1 bug which shows up as different "smaller" ones, like a flu causing different symptoms.)

So I've checked all the relevant things like cache etc, none of it fixed it for long, refresh etc fixes it temp.

  1. Scythe vision flashing. I've tried disabling any scripts altering the (default) colours and it still happens. I think when I add/remove a lot of stuff (like removing a large merger branch/cell) the scythe vision colours start flashing, a good example of it is if a cube (or branch) is reaped and scythe completed the overview will flash normal > reaped > sc'ed> repeat between the 3 constantly. If a cube is only completed then the ov. will flash normal > completed> repeat. etc.
    Usually at some point after (1.) if I don't refresh I get (2) (below).

  2. In-inspect sometimes, I don't know when but I think if I reap a cube and then either immediately or after inspecting a different cube I re-inspect the cube I reaped that cube has no 3D in inspect, but the trace is painted/coloured in 2D and if rereaped new reaped stuff are in cube/consensus and appear in overview. Usually shortly after this happens then I can no longer inspect or play and get this:
    Omni.play: Unable to initiate play. Game is in progress or UI is busy.
    and then I have to refresh.

I've heard in chat from others that they are also experiencing slow 2d loading in normal game and/or in inspect, as well as other stuff, so my guess is something's slow in servers/HQ end and it's inflicting different people in different ways.

some errors from console maybe they'll be of help:

https://pastebin.com/zrUgmNw4

So if you've been experiencing -new- bugs/slowness the last couple of weeks or so feel free to write here, if you have reproduction steps for the bugs even better, please do write them up as these do help the devs get to the problem faster.


#2

What exactly "flashing" means ? Cause i do not have any issue like this.


#3

Here's a couple gifs demonstrating the problem:


https://drive.google.com/open?id=1ZKIbYB5wXfe7sS-kCW5_WHvATg27cI_r
had to upload 2nd gif in gdrive lol
this happens multiple times per second once it starts, and every subsequent reap intensifies the prob (makes flashing more rapid) until (2) starts happening (unless I refresh), lol.

I assume you have scythe vision almost permanently on as a scythe/mystic, right? lol because i don't think it happens in any other heatmap/no heatmap on, lol.


#4

Ok, so it was what i was wondering by flashing. And so i do never had have this issue.
So yeah, i have permanently scythe or weight heatmap, and i also always use Show Me Me, so it probably cover the flashing issue and i do not see it.
By the way i never use any other heatmap for info.
I will try to reproduce the problem to see if i can add some info for devs.


#5
  1. okay that is not the same flashing i see, for me the whole cell go in deafult colour and then back to proper scythemap colours and often happen right after i go out of inspect/reap not sure witch of them. the blinking happen one time and then several seconds to next time.
  2. i am also getting the missing 3D in inspect but for me i when i lose it, it is when inspecting new cubes and sometimes i can play perhaps 5-6 cubes and suddenly get 3D back other times i need to refresh to get it back. also mostly i get the things i trace in 3d and only missing the seed or trace already in cube.
  3. something has happened with the sc-info so it is showing stashed cubes also, have to be a change in the ew code since it is affecting both player script.

#6

I have the same as @annkri with flashing - whole cell is flashing. It also happens, when ShowMeMe is in use - cell is highlighted in normal colors, then scythe heatmap, then showmeme.

Also missing 3D happens to me.

As for the 3rd problem, I think, it will be solved soon, as we (@crazyman4865 and I) have the necessary information to fix it.


#7
  1. I also experience Nseraf and annkri's problem where the whole cell changes to the base color, and the cubes start flashing colors (but only flashes between reaped and sced for me) but I also experience a very similar problem in OV where in zfish cells, some cubes don't even mesh/load at all and they only appear for a short period of time when I zoom in/click on a nearby cube. These issues only happened for me when working on zfish cubes.

  2. I have also experienced Nseraf's problem at times, but most of the time, even the 2D is missing and either I have to manually trace back in the seed and trace OR go to another cube, inspect, exit, go back to the cube I'm originally working on, and inspect again. It usually takes some time. I remember suggesting a "reload seed/trace" button to temporarily fix this problem.


#8
  1. I am also experiencing the flashing, seems to have two different expressions of it though, sometimes it is just flashing the reaped areas, other times it is flashing the whole cell to base color. Seems to happen more if I do a lot of inspecting of cubes, or a lot of completing.

  2. I am also getting the missing 3d, if i am in inspect i can use the delete seed button and then undo to make it appear, but if I am in standard play, i don't have that option. Once the 3d starts being disappeared it is intermittent, some cubes have it, some don't.

  3. I'm also having intermittently slow 2d loading. will be buzzing along, loading cubes at standard speed, then, boom, start getting cubes taking 2 mins or more to load (very rude during hh btw, lol) The 3d loads in fine, but the 2d just is slow. I've not changed anything with my network on my end, and it seems to occur more when i've been playing for a while. Often when i experience the slowness, other players also ask in chat if the game just got slow.

Here's the console from tonight's play session, this is experiencing flashing and missing seeds.

https://pastebin.com/C8p6mZ6Z

I'm seeing lots of 404's in there. And lots of things I dont understand (theres over 300 red errors in that paste)

Oh and a 4th issue i;m having, is i am sometimes unable to enter a cube in inspect, the game will make the noise like i've selected to go into a cube, but nothing happens. when this occurs i get a error of

Omni.play: Unable to initiate play. Game is in progress or UI is busy.

in the console


#9

I've identified the cause of the scythe vision flashing and have found a workaround (thanks @Nseraf)

Workaround:
Open EyeWire through this link:
https://eyewire.org/?show_stashed=true
(note: OV will start showing stashed cubes as either orange or black)

Technical info:
Cell.loadCubes filters out stashed cubes based on the URL param show_stashed having a value. This causes _tasks not having info about the stashed cubes in a cell.
The problem occurs when the scythe heatmap is reloaded: it can return stashed cube IDs apart from everything else, so when finishcoloring is called, the following snippet of code causes the issue:
if (_tasks[cubeid].status === 6) {
color = colors.stashed;
}

Here, it is assumed information for stashed cubes exists. The fix would be adding a check for show_stashed here as well. Example:
if ($.url().param('show_stashed') && _tasks[cubeid].status === 6) {
color = colors.stashed;
}


#10

Hi Folks,

Our developer, @Kelv has pushed a fix for flashing Scythe Vision heatmap. Please let us know if you are still (unfortunately) experiencing this issue.

Thanks,
M.


#11

yeah i think it's fixed, ty! :smiley:
I still get the no 3d in inspect sometimes but less frequently.