My 3D view isn't showing a coloured part

#1

My 3D view isn’t showing any coloured part of the cube I’m working on (I’m only in tutorials). It shows a colored part on the 2D view, but not on the 3D. 

#2
If the 3D-view is completely missing, it is most likely your graphics card that doesn't support 10 varying vectors.
You can check this here, if you like: http://webgl-bench.appspot.com/

There should be an entry in the results:
caps/MAX_VARYING_VECTORS                 |            X |

If X is below 10, there's your problem.
I am pretty sure the developers will take care of this as soon as things are a bit... less hectic. ;-)


#3

Hey, my sister is also having this problem (playing on a slightly older MacBook with Chrome) - I wanted to show her but the lack of a 3D view makes checking really hard!


I ran the above test and her MAX_VARYING_VECTORS value was 16.

I know the devs are busy, but thought another report could be helpful for debugging :slight_smile:

Thanks!
#4

Thanks, we’ll keep looking into it and see if we can fix it up!

#5

I am having the same problem with the 3D cube view missing .  Just started tonight.  The 3D cube layer is more transparent tonight as well which is helpful when working through the layers.  Been tracing since November and never had this problem before.  I ran the above test with max_varying_vectors being 10.


Thanks
#6

Hi ouiz, and thanks for reporting!


The bug you were/are encountering is however a different one and affects everybody :slight_smile: The team is working on it.
#7

Just started happening here too.

#8

In my opinion, the best thing to do right now is to skip those cubes. One often misses the details, when only relying on the 2d-slice…

#9

Thanks nkem,  I have been skipping the blank cells.  I figure they will come around again at some point with the colored part intact.  Technology does provide so many wonderful opportunities to work out puzzles.

#10

I’m sorry I haven’t been on the forum since the 17th but, nkem appears to have presented the reason why my 3D view wasn’t working. My graphics does not support 10 varying vectors, only 8.

#11

Me too - only 8 vectors; 3D view is there but without the color. 

#12

I ran the test above and i got this:

caps/MAX_VARYING_VECTORS                 |            8

Is there a way for me to do something so I can see the colored figure in 3D?
#13

What are your system specs? Are you using the latest drivers for your graphics card?

#14

Thanks !  I have the same problem. 

#15

This has been an increasing problem for me over the last week or so. At first it was approx. every 10 cubes, then it got down to every 2nd or 3rd.  Today it doesn’t seem to load the 3D neuron at all, no matter how many times I reload the webpage.  I’m on a Retina Macbook Pro with OS X 10.8.2 using Chrome (Version 26.0.1410.65) which is uptodate


 caps/MAX_VARYING_VECTORS                 |           31


here are the complete results if that is any use:


userAgent = Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_2) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.65 Safari/537.31
GL_VERSION = WebGL 1.0 (OpenGL ES 2.0 Chromium)
GL_VENDOR = WebKit
GL_RENDERER = WebKit WebGL
GL_SHADING_LANGUAGE_VERSION = WebGL GLSL ES 1.0 (OpenGL ES GLSL ES 1.0 Chromium)
±-----------------------------------------±-------------+
| metric                                   | value        |
±-----------------------------------------±-------------+
| vtf/l1.dim128.strip.tps                  |   1441383425 |
| vtf/l1.dim128.strip.dps                  |        44683 |
| uniqtex/l4.dim32.strip.tps               |    108160359 |
| uniqtex/l4.dim32.strip.dps               |        56275 |
| uniqtex/l4.dim64.strip.tps               |    452812500 |
| uniqtex/l4.dim64.strip.dps               |        57044 |
| caps/ALIASED_LINE_WIDTH_RANGE0           |            1 |
| caps/ALIASED_LINE_WIDTH_RANGE1           |           10 |
| caps/ALIASED_POINT_SIZE_RANGE0           |            1 |
| caps/ALIASED_POINT_SIZE_RANGE1           |           63 |
| caps/ALPHA_BITS                          |            8 |
| caps/BLUE_BITS                           |            8 |
| caps/GREEN_BITS                          |            8 |
| caps/MAX_COMBINED_TEXTURE_IMAGE_UNITS    |           16 |
| caps/MAX_CUBE_MAP_TEXTURE_SIZE           |        16384 |
| caps/MAX_FRAGMENT_UNIFORM_VECTORS        |         1024 |
| caps/MAX_RENDERBUFFER_SIZE               |        16384 |
| caps/MAX_TEXTURE_IMAGE_UNITS             |           16 |
| caps/MAX_TEXTURE_SIZE                    |        16384 |
| caps/MAX_VARYING_VECTORS                 |           31 |
| caps/MAX_VERTEX_ATTRIBS                  |           16 |
| caps/MAX_VERTEX_TEXTURE_IMAGE_UNITS      |           16 |
| caps/MAX_VERTEX_UNIFORM_VECTORS          |         1024 |
| caps/MAX_VIEWPORT_DIMS0                  |        16384 |
| caps/MAX_VIEWPORT_DIMS1                  |        16384 |
| caps/RED_BITS                            |            8 |
| caps/SAMPLE_BUFFERS                      |            0 |
| caps/SAMPLES                             |            0 |
| caps/STENCIL_BITS                        |            0 |
| caps/SUBPIXEL_BITS                       |            8 |
±-----------------------------------------±-------------+

#16

Are other people having this problem?  Could you record a few cube numbers?  Sometimes the meshes are just missing, but I doubt it would happen for that many cubes, and only for you.

#17

Well, wouldn’t you know it. This happened for me each day for about a week so then I posted here. Of course… the next day I login and no problems!  So… my apologies.  Everything working fine today.  Sorry!

#18

No worries!  Problems are still problems even if they go away.  We’ll keep an eye on it, and if we find things that we can reproduce, we’ll fix em.  There’s probably still a few cubes that need to be remeshed in there…

#19

Same problem here,  left pane shows no color, right side color.  Checked the WebGL caps max varying vectors is 10. Everything worked correctly yesterday. Ideas? Is it my computer or a program glitch?

#20

changed cells and everything back as it should be.